Jump to content


Toggle shoutbox Shoutbox Open the Shoutbox in a popup

Account setup issues please email RegalGSusers@gmail.com

@  Marchi1 : (21 April 2017 - 01:28 AM)

Whoa new guys....

@  jesman : (19 April 2017 - 01:24 PM)

random hello

@  BillyrayM : (19 April 2017 - 06:18 AM)

Any 1 on that can help me with my post?

@  BillyrayM : (17 April 2017 - 10:21 PM)

:sad-roulette:

@  Mitchell075 : (10 April 2017 - 03:39 AM)

Hey!

@  DunkinDomnuts : (07 April 2017 - 09:10 PM)

Hey guys long time no talk

@  Chrisolds : (03 April 2017 - 08:15 PM)

Thanks Dave, yeah I'm sure it is these people are just being annoying and I just wanted to let you know about it that's all. Thanks again

@  White Regal GS : (26 March 2017 - 06:00 PM)

Looking for a GSX grille for my 99

@  WildGS : (25 March 2017 - 06:01 AM)

not sure if I cleaned them all up or not...it's getting hard to keep up

@  Chrisolds : (25 March 2017 - 05:18 AM)

Haha this looks like a mess lol okay so no coy and paste it worked now just click on the blue link and you're good to go. Thanks Dave

@  Chrisolds : (25 March 2017 - 05:16 AM)

Copy and paste this link into your browser== http://www.regalgs.org/statuses/all/

@  Chrisolds : (25 March 2017 - 05:15 AM)

*it looks like part of it

@  Chrisolds : (25 March 2017 - 05:14 AM)

copy and paste the link I posted and use the second link I posted it should not have LINK behind the first one I wrote that but it looks likempart of it

@  Chrisolds : (25 March 2017 - 05:13 AM)

Your going to have to coy

@  Chrisolds : (25 March 2017 - 05:12 AM)

http://www.regalgs.org/statuses/all/

@  Chrisolds : (25 March 2017 - 05:11 AM)

http://www.regalgs.org/statuses/all/ LINK

@  Chrisolds : (25 March 2017 - 05:11 AM)

Here you go Dave

@  WildGS : (25 March 2017 - 12:53 AM)

shoot me a link to one of the threads

@  Chrisolds : (25 March 2017 - 12:27 AM)

WildGS, if you look in the "all updates" section there is a ton of spam a lot of Russian crap and how to lose weight. Just wanted to let you know..

@  Chrisolds : (25 March 2017 - 12:24 AM)

WildGS,


Photo

Have a few questions about fuel pump on Buick Regal/New from Paris ky

Fuel Pump Buick Regal

  • Please log in to reply
4 replies to this topic

#1 BillyrayM

BillyrayM

    Newbie

  • Members
  • Pip
  • 2 posts
  • LocationParis Ky 40361
  • First Name:
    Billyray

Posted 17 April 2017 - 10:15 PM

Hello every one! I have a 98 Buick Regal GS Supercharged, So long story short my regal has been siting till I had the money to get a fuel pump.

So I got the new fuel pump from rockauto.com for about $60 with S/H. So I put the thing in yesterday but I look at the hook ups on the top and the new fuel pump came with a new GM wiring harness so I replaced it, but on my regal I noticed that the old pump only had 1 wire hook up to the old pump but there is 2 spots for wires?

I looked at some pics/vids but I cant find anything about why my regal has only 1 wire to hook up to the fuel pump, when there is 2 spots on the fuel pump for hook ups.

I also looked underneath the car and no other wires are there.

SO I just need to know if its goanna be okay or do I need to fix this?

Thanks,

BillyrayM


  • 0

#2 b4black

b4black

    Been There. Done That.

  • Members
  • PipPipPipPipPip
  • 839 posts
  • LocationAurora, IL
  • First Name:
    Rich

Posted 18 April 2017 - 01:32 PM

One should be for the fuel pump and fuel level sender unit.  Four wires.

 

The other is for the pressure sensor and is part of the EVAP system (3 wires).  It's the sensor that sets the check engine light if you leave the gas cap off.   Maybe someone removed this.

 

 

I'd hook up the one connector and if everything seems OK, then don't worry.


  • 0

#3 scottydoggs98

scottydoggs98

    I Know Regals

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,156 posts
  • LocationNJ
  • First Name:
    scott

Posted 18 April 2017 - 09:46 PM

my stock f/p two plugs, looks like 4 wires. i replaced this and also had to cut and splice the new plug on there. 

 

018_zpsexvv3hxp.jpg

 

worst comes to worst, swap the pump from the new canister to your old canister and put the stock plug back on, if you left its wires  long enough. 

 

and grease the piss out of the o ring  then smear more grease on it once its seated under the canisters top lip, then push down and wiggle till it pops in place and dont move side to side in the hole, or you'll be back in there doing it again when it leaks after you fill the tank up. 


  • 0

#4 BillyrayM

BillyrayM

    Newbie

  • Members
  • Pip
  • 2 posts
  • LocationParis Ky 40361
  • First Name:
    Billyray

Posted 19 April 2017 - 06:38 AM

Okay sorry for the late response,

The wire I'm talking about that was never hook up is the "pressure sensor".

So I put the new pump in and cut the old fuel pump & fuel level sender unit wire plug to replace it with the new GM fuel pump & fuel sender unit wire plug that came with the new fuel pump. The hard part was the big O-Ring like you guy's said it would be but I believe its on tight, I also used the old fuel pump rubber gasket(was in great shape) because the new gasket just seemed way to big and thin.

I still have a few more things to do on my regal before I can start it, so I am going to try to get it back together with in a few days to update you guy's on the status of the fuel pump(if it works or leaks). As I am a new member of the site I didn't think of taking any pics to show you guy's so sorry for that.

But you guy's have help out a lot so thanks for the help and support.

Thanks BillyrayM


Edited by BillyrayM, 19 April 2017 - 06:40 AM.

  • 0

#5 scottydoggs98

scottydoggs98

    I Know Regals

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,156 posts
  • LocationNJ
  • First Name:
    scott

Posted 19 April 2017 - 08:40 PM

i forgot to say that about the pump O ring. the old stock one is a much better fit. 

 

you can still get that ring back on with the pump not seated right, i know this first hand lol  grease made it pop in place. i failed at it two times before not using grease, found the o ring laid up on the level sensor in the tank both times. 

 

fill the tank, you will know asap if the o ring is in place or not, cause it leaks and smells of gas pretty bad. 


  • 0





Also tagged with one or more of these keywords: Fuel Pump, Buick Regal

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

BoHeGeHa Dark Blue 2.1.1 © Thomas Yugar (Chemical Chaos)
Official upgrade for IPB 2.3.x © Michael ( Dev Fuse )
3.X © Upgrade by Dumbledore ( Tppskinning )