Jump to content


Toggle shoutbox Shoutbox Open the Shoutbox in a popup

@  scottydoggs98 : (03 November 2017 - 11:49 PM)

no way you blew it up lol coupler might be bad already if its clicking when you turn th epulley back and fourth .

@  griff-97gs : (03 November 2017 - 04:43 PM)

blew my supercharger this weekend wen my serpentine belt snapped coming off the freeway anyone know the cost to hav one rebuilt

@  Loly : (23 October 2017 - 08:29 PM)

Check out MPD for hoods, I have one and Crazyguy03 has one as well and they are great for heat release and Cold Air (RAM AIR). Here's the link.... http://www.mpd1.com

@  bad108 : (19 October 2017 - 02:14 PM)

hoods

@  jwguinn : (16 October 2017 - 02:36 PM)

Anyone know the actual flow rate on siemens 60lb injectors? I have seen anywhere 60-65, that is big difference. I used 62 in my tune...

@  jwguinn : (19 September 2017 - 01:35 AM)

nvm I found it. ripoff! I think I will make one...

@  jwguinn : (18 September 2017 - 03:31 PM)

Anyone know the part number or where to get a replacement for the short very curved vacuum line that connects to the throttle body mine is split where it connects...?

@  EnderDRM : (13 September 2017 - 12:04 AM)

So the headers and 3" exhaust is on. Sounds pretty good.

@  bigbird90650 : (31 August 2017 - 09:12 AM)

I'm looking for regal "GSX" emblems. Anyone have any for sale? I am looking for the OEM SLP GSX chrome emblems. Thanks

@  EnderDRM : (30 August 2017 - 09:27 PM)

Hi all, I thought I would get the plugs replaced while the headers are being installed. Recomendations for plugs?

@  Marchi1 : (25 August 2017 - 02:08 PM)

Speedy daddy is the default cheap. I have been running pacesetters for 10 years and with the exception of one issue have had no problems.

@  scottydoggs98 : (22 August 2017 - 02:02 AM)

every now and again you get a poorily built cross over pipe and they dont fit right. only issue with them

@  scottydoggs98 : (22 August 2017 - 02:02 AM)

those are what most of use run, good ol speed daddy

@  EnderDRM : (22 August 2017 - 01:37 AM)

http://speed-daddy.c...cription_tabbed

@  EnderDRM : (22 August 2017 - 01:36 AM)

so what about these?

@  Fast86GN : (21 August 2017 - 09:10 PM)

Where the hell is everyone?

@  chromeGS : (19 August 2017 - 01:07 AM)

Long time since ive been on... hows everyone been

@  WildGS : (12 July 2017 - 04:11 AM)

You are making me do things....I need to spend time on stupid car stuff

@  Marchi1 : (12 July 2017 - 02:35 AM)

How is everyone doing tonight?

@  scottydoggs98 : (09 July 2017 - 12:52 PM)

some of the 99 pcms will work take a 01 bin, those you can change the vin # ive found.


Photo

Have a few questions about fuel pump on Buick Regal/New from Paris ky

Fuel Pump Buick Regal

  • Please log in to reply
4 replies to this topic

#1 BillyrayM

BillyrayM

    Newbie

  • Members
  • Pip
  • 3 posts
  • LocationParis Ky 40361
  • First Name:
    Billyray

Posted 17 April 2017 - 10:15 PM

Hello every one! I have a 98 Buick Regal GS Supercharged, So long story short my regal has been siting till I had the money to get a fuel pump.

So I got the new fuel pump from rockauto.com for about $60 with S/H. So I put the thing in yesterday but I look at the hook ups on the top and the new fuel pump came with a new GM wiring harness so I replaced it, but on my regal I noticed that the old pump only had 1 wire hook up to the old pump but there is 2 spots for wires?

I looked at some pics/vids but I cant find anything about why my regal has only 1 wire to hook up to the fuel pump, when there is 2 spots on the fuel pump for hook ups.

I also looked underneath the car and no other wires are there.

SO I just need to know if its goanna be okay or do I need to fix this?

Thanks,

BillyrayM


  • 0

#2 b4black

b4black

    Been There. Done That.

  • Members
  • PipPipPipPipPip
  • 853 posts
  • LocationAurora, IL
  • First Name:
    Rich

Posted 18 April 2017 - 01:32 PM

One should be for the fuel pump and fuel level sender unit.  Four wires.

 

The other is for the pressure sensor and is part of the EVAP system (3 wires).  It's the sensor that sets the check engine light if you leave the gas cap off.   Maybe someone removed this.

 

 

I'd hook up the one connector and if everything seems OK, then don't worry.


  • 0

#3 scottydoggs98

scottydoggs98

    I Know Regals

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,248 posts
  • LocationNJ
  • First Name:
    scott

Posted 18 April 2017 - 09:46 PM

my stock f/p two plugs, looks like 4 wires. i replaced this and also had to cut and splice the new plug on there. 

 

018_zpsexvv3hxp.jpg

 

worst comes to worst, swap the pump from the new canister to your old canister and put the stock plug back on, if you left its wires  long enough. 

 

and grease the piss out of the o ring  then smear more grease on it once its seated under the canisters top lip, then push down and wiggle till it pops in place and dont move side to side in the hole, or you'll be back in there doing it again when it leaks after you fill the tank up. 


  • 0

#4 BillyrayM

BillyrayM

    Newbie

  • Members
  • Pip
  • 3 posts
  • LocationParis Ky 40361
  • First Name:
    Billyray

Posted 19 April 2017 - 06:38 AM

Okay sorry for the late response,

The wire I'm talking about that was never hook up is the "pressure sensor".

So I put the new pump in and cut the old fuel pump & fuel level sender unit wire plug to replace it with the new GM fuel pump & fuel sender unit wire plug that came with the new fuel pump. The hard part was the big O-Ring like you guy's said it would be but I believe its on tight, I also used the old fuel pump rubber gasket(was in great shape) because the new gasket just seemed way to big and thin.

I still have a few more things to do on my regal before I can start it, so I am going to try to get it back together with in a few days to update you guy's on the status of the fuel pump(if it works or leaks). As I am a new member of the site I didn't think of taking any pics to show you guy's so sorry for that.

But you guy's have help out a lot so thanks for the help and support.

Thanks BillyrayM


Edited by BillyrayM, 19 April 2017 - 06:40 AM.

  • 0

#5 scottydoggs98

scottydoggs98

    I Know Regals

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,248 posts
  • LocationNJ
  • First Name:
    scott

Posted 19 April 2017 - 08:40 PM

i forgot to say that about the pump O ring. the old stock one is a much better fit. 

 

you can still get that ring back on with the pump not seated right, i know this first hand lol  grease made it pop in place. i failed at it two times before not using grease, found the o ring laid up on the level sensor in the tank both times. 

 

fill the tank, you will know asap if the o ring is in place or not, cause it leaks and smells of gas pretty bad. 


  • 0





Also tagged with one or more of these keywords: Fuel Pump, Buick Regal

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

BoHeGeHa Dark Blue 2.1.1 © Thomas Yugar (Chemical Chaos)
Official upgrade for IPB 2.3.x © Michael ( Dev Fuse )
3.X © Upgrade by Dumbledore ( Tppskinning )