Jump to content


Toggle shoutbox Shoutbox Open the Shoutbox in a popup

@  Frank : (15 February 2019 - 03:42 PM)

Hello everyone! Its been a long time!. Looking to get back into the game. Anyone have a GS on the east coast they wish to part with?

@  ejguillot : (14 February 2019 - 09:08 PM)

Still have a Regal GS project that has taken way too long to build, and it's nowhere near done.

@  ejguillot : (14 February 2019 - 09:08 PM)

Same here.

@  Tobias05 : (09 February 2019 - 04:20 PM)

Haven't been on in a while, hope everyone is doing well!

@  fastnysix : (05 February 2019 - 03:40 PM)

Yes, still here

@  tpivette : (04 February 2019 - 02:26 AM)

Showing some RegalGS love. Anyone still active and lurking?!?

@  marcleach75 : (03 January 2019 - 01:59 PM)

You too bubba.

@  fastnysix : (02 January 2019 - 01:29 PM)

Happy New Year

@  marcleach75 : (31 December 2018 - 03:21 PM)

Hello.

@  WildGS : (27 December 2018 - 05:53 PM)

hello people!

@  buck531 : (24 December 2018 - 04:11 AM)

uhhh sure?

@  shindaiwadealer : (23 December 2018 - 05:32 AM)

Emergency ??? Are Napa crank sensors good??

@  marcleach75 : (19 December 2018 - 08:22 PM)

You too bubba.

@  Regalzzz : (13 December 2018 - 05:44 AM)

I hope everyone has a Merry Christmas on here!!

@  ejguillot : (13 December 2018 - 01:57 AM)

I plan to be on here more often. Don't want this site to fade away.

@  ejguillot : (13 December 2018 - 01:51 AM)

hello all

@  LS5454SS : (25 November 2018 - 01:45 AM)

@wildgs :*(

@  WildGS : (15 November 2018 - 02:48 AM)

almost forgot about this place until the bill showed up....

@  marcleach75 : (24 October 2018 - 07:30 PM)

Are you sure it's the actuator not the vacuum line?

@  gumba : (23 October 2018 - 11:35 PM)

need help with blend door actuator is there one on the passenger side?


Photo
- - - - -

Creaking front suspension


  • Please log in to reply
1 reply to this topic

#1 Nat obrien

Nat obrien

    Wheres the Newbie Guide?

  • Members
  • PipPip
  • 35 posts
  • LocationMichigan
  • First Name:
    Nathan

Posted 11 July 2018 - 11:51 PM

Title says it all, I've done sway bar bushings, sway bar links, new struts with springs, trans mount, wheel hubs, brakes rotors and calipers are a couple months old. I can make the car make the noise from a 5 mph roll by pushing the gas or jumping on the brakes,but when parked it's doesn't make a sound pushing up and down on the suspension. I need some of your guys w body wisdom lol only things I haven't changed in the front are the control arms and tie rods and they seem to be in good shape and I have greased them. Feels and sounds like it's on the driver side if that makes a difference. I can feel the creaking through the floor pans
  • 0

#2 OhMyGS

OhMyGS

    RGS.org VIP Server Upgrade supporter

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,770 posts
  • LocationNorthern Illinois
  • First Name:
    Alan

Posted 12 July 2018 - 03:13 AM

Mine came from the passenger side. The lower motor mounts were squeaking. I proved it by removing the dog bones and rocking the engine front to rear. Then I sprayed it with WD-40...squeak went away. Later, I removed the mount and spread a little Prothane grease on it. Squeak never returned. Really cost me nothing but a little time.
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

BoHeGeHa Dark Blue 2.1.1 © Thomas Yugar (Chemical Chaos)
Official upgrade for IPB 2.3.x © Michael ( Dev Fuse )
3.X © Upgrade by Dumbledore ( Tppskinning )