Jump to content


Toggle shoutbox Shoutbox Open the Shoutbox in a popup

@  Crazyguy03 : (07 July 2019 - 07:50 PM)

Yes

@  tpivette : (05 July 2019 - 02:47 AM)

I stop back every once in a while

@  ejguillot : (30 June 2019 - 08:36 PM)

Wow, is anyone on anymore? Leave a shoutbox comment please!

@  ejguillot : (10 June 2019 - 04:28 PM)

unfortunately, I have to agree.

@  buck531 : (09 June 2019 - 03:14 AM)

this place is dead.

@  buck531 : (09 June 2019 - 03:14 AM)

congrats Alan!

@  buck531 : (30 April 2019 - 02:14 PM)

DOH

@  ejguillot : (22 April 2019 - 10:40 PM)

I haven't. Still on here occasionally, Facebook is the work of Satan. :P

@  marcleach75 : (08 April 2019 - 05:22 AM)

Has anyone had an issue with wobbling at around 20 to 35 mph?

@  Tobias05 : (06 March 2019 - 09:38 PM)

...trying to convince the wife not to throw a stock replacement system back on...

@  Tobias05 : (06 March 2019 - 09:38 PM)

... i think they have a house brand muffler now? Used to be a magnaflow...

@  Fast86GN : (04 March 2019 - 07:05 PM)

I don't think it would that loud probably depends on the mufflers used?

@  Tobias05 : (01 March 2019 - 03:31 PM)

ZZP 3IN SS Regal exhaust w/plog and DP too loud for a DD?

@  tpivette : (17 February 2019 - 01:03 AM)

Don't know where on the east coast you are, but there's one for sale on craigslist in south Jersey...https://southjersey.craigslist.org/cto/d/browns-mills-98-buick-regal-gs/6779489044.html

@  Frank : (15 February 2019 - 03:42 PM)

Hello everyone! Its been a long time!. Looking to get back into the game. Anyone have a GS on the east coast they wish to part with?

@  ejguillot : (14 February 2019 - 09:08 PM)

Still have a Regal GS project that has taken way too long to build, and it's nowhere near done.

@  ejguillot : (14 February 2019 - 09:08 PM)

Same here.

@  Tobias05 : (09 February 2019 - 04:20 PM)

Haven't been on in a while, hope everyone is doing well!

@  fastnysix : (05 February 2019 - 03:40 PM)

Yes, still here

@  tpivette : (04 February 2019 - 02:26 AM)

Showing some RegalGS love. Anyone still active and lurking?!?


scottydoggs98

Member Since 15 Feb 2014
Offline Last Active Yesterday, 11:22 PM
-----

#400814 Problem please help

Posted by scottydoggs98 on 26 June 2016 - 01:21 PM

sounds like you need a tune up, or a clogged cat. what plugs you use last, and the gap? 

 

some how im sure your not scanning for kr. most canned tunes raise the timing and with no flow mods at all, your asking for a chipped piston.

 

when you get kr the pcm pulls timing and the engine will fall on its face if theres enough kr.

 

cheap parts store wires work just fine to btw. you dont need 10 mm wires. 


  • 1


#392711 What did you do to your car today???

Posted by scottydoggs98 on 31 May 2015 - 12:33 PM

over the past few weeks ive been prepping a  bottom swapping engine for my regal. 

 

its a 96 l36 with 109,000 on the clock. it wa torn down and every last gasket and seal was replaced.

 

002_zpsqtatlpw0.jpg

 

got a newer set of l67 heads, cleaned up the castings and polished em up.

 

006_zps6gl1nht2.jpg

 

003_zpsom8kk6xa.jpg

 

did some of that valve lapping. boy they needed it bad.

 

001_zpsdlvzryom.jpg

 

002_zpseluzhl5u.jpg

 

003_zps9vlim5fq.jpg

 

004_zpsclsegj5a.jpg

 

 

005_zpslgwaeadt.jpg

 

and then......................

 

005_zpsog7kldke.jpg

 

004_zps0on8ltxa.jpg


  • 1


#390916 Regal LS - LIM issue or worse?

Posted by scottydoggs98 on 23 March 2015 - 02:23 PM

i always clean a engine if its that dirty before working on it. who wants to work on a filthy engine?  spray the block from underneath too, and as much of the tranny as you can. car ramps help out a lot here.

 

id get a mechanical oil pressure gauge on there to test what your oil pressure is at idle and when giving it gas. you can rent one from the parts store, free rental deal, leave a deposit, they refund it when you bring the tool back.  you remove the oil pressure sensor near the oil filter and put the hose from the gauge in the hole. that hole is a tapered thread, do not drive the sensor or the gauge hose in any deeper then snug, or you'll crack the oil filter housing.

 

the low oil pressure light dont come on till it see's 5 psi or less, and then its to late. you should see a min of 20 psi warmed up at idle.

 

a oil pans no fun if your familiar with working on cars. kudos for taking the job on.  if you see low o/p you'll be taking it off one more time tho. second time at any thing is easier tho. 


  • 1


#390914 Regal LS - LIM issue or worse?

Posted by scottydoggs98 on 23 March 2015 - 01:12 PM

thats not steam coming form your oil cap. its oil burning off your engine. 

 

for the love of god, go get like 4 cans of de greaser and clean your engine before it catches fire on you. then change your valve cover gaskets and lim gaskets if they are black plastic crap still.

 

im not kidding, your a rolling fire hazard. clean that mess up asap! 

 

your oil pick up, that needs to be a solid seal or it can suck air. ( and you'll have low or no oil pressure) i cant believe you'd see and leave a any part of the old gasket. thats a no no all day long.

 

the axle your best off just changing it if the boot is torn and slinging grease. its on borrowed time now. it will start to fail with no grease in there.


  • 1


BoHeGeHa Dark Blue 2.1.1 © Thomas Yugar (Chemical Chaos)
Official upgrade for IPB 2.3.x © Michael ( Dev Fuse )
3.X © Upgrade by Dumbledore ( Tppskinning )